Intermittent Limp Mode - IMBOC
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 04-13-2017, 10:11 AM Thread Starter
 
Join Date: Sep 2010
Location: pensacola, fl
Posts: 8
Intermittent Limp Mode

2008 Bullitt with Edelbrock E Force blower. In the middle of trouble shooting the codes of P2100, P2104, P2107, P2110. I can clear codes and car cranks and runs normally until fault reoccurs and Limp Mode. I cannot determine what parameters cause the fault.
Spoke with Brenspeed who performed mod in March 2016 and Doug offered some history of potential problems. Spoke with Edelbrock and learned that OEM TPS will not fit Edelbrock blower. Ford has redesigned TPS and now not compatible with E Force blower. Edelbrock says they purchased OEM TPS supply from Ford and is available as Edelbrock part no. 37-3537.
To replace the complete throttle body would require purchase of Edelbrock throttle body housing AND Ford throttle body so as to cannabalize Ford parts to Edelbrock housing.
Doug from Brenspeed also discussed a throttle stop set screw (?) which may back out and cause sensor fault.
I need any help regarding these issues.
rdf15 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 04-13-2017, 12:06 PM

Monster BullittHead
 
Join Date: Feb 2013
Location: Pottstown, PA
Posts: 738
May or not be helpful, but I had another car that had an issue with the motor that ran the throttle body. Basically the gears would strip inside, and it would run OK sometimes, limp mode other times (not a mustang, turbo dodge). The solution was a new throttle body.

FR500S mufflers, 2011+ 13.2inch rotor upgrade, MGW shifter, BMR adjustable Panhard bar, GT500 finned Differential cover ~ "Thats thinkin with your dipstick Jimmy!" ~
Bullitt2059 is offline  
post #3 of 3 (permalink) Old 04-14-2017, 10:12 AM

You Broke the Server!
 
first ford's Avatar
 
Join Date: Nov 2008
Location: new jersey
Posts: 6,123
borrow a throttle body from someone and see if it heals it

Vortech V-7 YSI ,Kooks LT W/ H pipe, 62 Mil TB, 3.5"Dynotech shaft, Steeda swaybar & end links,SLP exhaust, T56 magnum 6spd trans,Mcleod clutch ,steeda lca BMR uca,FRPP axle girdle , Koni yellows, Moser axles,UMI pan hard bar,SLP line lock, boost gauge, wideband ,BMR relocation brackets,B 302 stroker,SHR louvers,Steeda torque boxs,Prothane motor mounts,CHE torque limiter,Raptor shift light, Baer Decelarotors, Nitto NT05 295/45/18 out back, torq thrust wheels, Comp cams,MRT Custom shift knob,cervini cobra R hood 682 RWHP/577T /2014 GHIG GT lightly modded .. so far
first ford is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the IMBOC forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome