IMBOC - Reply to Topic
Thread: No power Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the IMBOC forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
04-04-2019 03:08 PM
bullit4404 Fusible link may be blown. Short in the alternator. Check all positive cables. Load test battery. You'll need a voltmeter to check all the circuits. Pull the top off the fuse box. Odd that negative post was melted, may have been loose?
04-04-2019 01:32 PM
pwd72s An electrical expert may be needed here to find what else was fried.
04-03-2019 11:01 PM
#94 A short? Hot cable to starter or alternator shorted somewhere?
04-03-2019 09:20 PM
CarolinaBullitt4132
No power

My car shut off coming home today the ground side on the battery completely melted we put and new cable end on but the car still has no power but battery is good any advise on what to look for thanks

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

 
For the best viewing experience please update your browser to Google Chrome