Mustang Bullitt Forum banner

1 - 13 of 13 Posts

·
Premium Member
Joined
·
39 Posts
Discussion Starter #1
Has anyone had a problem with their speakers?

Yesterday I noticed an odd sound coming from the rear passenger side of my 19 Bullitt. I wasn't sure what it was and thought it was something on the radio.

Today it is very obvious that the speaker is blown. I don't listen to my music very loud so I can't think of a reason why it would be damaged. I'm the first owner and no one else drives my mustang.

Any feedback on this topic would be appreciated.

Kary
 

·
Registered
Joined
·
83 Posts
Are you sure the speaker is blown, and not a rattle back there? I'm also thought a left door speaker was blown, but it's the damn door panel. Or a window regulator tube that somebody reported. It only happens in certain resonant frequencies. I can play the stereo louder with other music and no rattles. I said that because if you don't play music loud, it's extremely unlikely that you'd blow a speaker. Play that music with the ignition on, climb back and poke around, and also inside the trunk, and see if it's the speaker, or something else. These cars rattle like freaking crazy; extremely frustrating. Took the car for a day trip today, and the C-pillar is now rattling like crazy, along with both door panels. Geez. Will have to at least remove the stupid door panels and quiet them down. The C-rattle is going to be more complicated to locate. At any rate, let us know what you found. Good luck.
 

·
Premium Member
Joined
·
39 Posts
Discussion Starter #3
Well, it's both sides I hope it isn't some other issue. New speakers would be an easy fix. I made an appointment at the dealership for them to see if it is the speakers. Cross your fingers. I will update everyone once I find out. Thank you for the reply.
 

·
Administrator
Joined
·
6,243 Posts
Definitely let us know. Good luck!
 

·
Registered
Joined
·
4 Posts
Has anyone noticed that the back speakers are hardly heard at all? I keep saying this can't be right...the back are in an elaborate cage built but when trying to adjust sound inside cabin I can barely hear them...Is this the normal sound from these speakers? I can't see or feel any cut outs for the speakers they are firing against the board ..Can anyone help with this? Or is this the normal setup? Can't imagine this is what they strive for. Thanks..........
 

·
Administrator
Joined
·
6,243 Posts
Have you adjusted the sound settings to ensure the cabin is covered? You should definitely hear something from the rear. Do you have the standard or the B&O system?
 

·
Premium Member
Joined
·
39 Posts
Discussion Starter #7
Have you adjusted the sound settings to ensure the cabin is covered? You should definitely hear something from the rear. Do you have the standard or the B&O system?
Yes, it is definitely the speakers. I've changed settings from front to back to confirm it is the rear speakers and both of them. I have an appointment Thursday this week. They said if it is confirmed to be the speakers then it would be included in my warranty and they would be replaced. Of course, they wouldn't have them on hand so I would have to have another appt. to have it fixed. Typical.

I will continue to keep you up to date.
 

·
Administrator
Joined
·
6,243 Posts
Yes, it is definitely the speakers. I've changed settings from front to back to confirm it is the rear speakers and both of them. I have an appointment Thursday this week. They said if it is confirmed to be the speakers then it would be included in my warranty and they would be replaced. Of course, they wouldn't have them on hand so I would have to have another appt. to have it fixed. Typical.

I will continue to keep you up to date.
Crossing my fingers for you!
 
  • Like
Reactions: Karykid

·
Registered
Joined
·
83 Posts
So B&O nor not? You didn't say :). Good luck.
 

·
Registered
Joined
·
4 Posts
Well I just had my first oil change today and have a not so friendly ford dealership..Can't bring your own oil and unless its motor-craft you warranty will be void...I bought car from different dealer..I called them and they said the oil I bought is great and it will NOT void your warranty..But beside that I had them look at my B&O system I can not hear anything from back speakers and now sub-woofer..they think I may have bad amplifier? I have to make a separate appointment to get it in writing and they will check it out..The manager was nice I went to other mustangs to hear their systems and mine is diffidently not working.....it sounds terrible...hopefully they can fix it..... Anyone else have issues and where is amplifier located.? thanks a million...Do we have reproduction numbers on 2019 Bullitt yet?
 

·
Premium Member
Joined
·
39 Posts
Discussion Starter #12
Okay, so I'm an idiot. Had the appt to have the speakers checked and I had to get the show stuff out of my trunk. Just as a thought I checked the speakers after removing items. Noise is gone. So embarrassing.

So owner issue not Bullitt. :)
 

·
Premium Member
Joined
·
39 Posts
Discussion Starter #13
Yes I have noticed that too.

The back speakers being hard to hear.
 
1 - 13 of 13 Posts
Top