Mustang Bullitt Forum banner

1 - 4 of 4 Posts

·
Premium Member
Joined
·
420 Posts
Discussion Starter #1
I added a set of rear mud flaps to my Bullitt today. Here's the caution! I found at least three lug nuts on each wheel (I checked the front also) that I could turn with no pressure on my four way lug wrench. I am far from being a mechanic but I think we should all check and re tighten our lug nuts as necessary.
 

·
Registered
Joined
·
214 Posts
I noticed a slight vibration around 80-90 mph. So, went home and check a few things over and foud three loose lug nuts on the right front. Also, some of the nuts were chewed up like they held the driver on an angle when they tightened them. We'll probably be finding more loose or missing fastners as they are probably rushing production. It wouldn't hurt to go over some of them on a rainy day.
 

·
Registered
Joined
·
130 Posts
After 400 miles, I started feeling a "clunk" when I shifted from reverse to 1st, and occassionally when I shifted hard from 1st to 2nd.

Then on our 800 mile weekend roadtrip it started getting worse... when we got home I took the car to the dealer service. They had it for the day, and found that the Transmission Mounting Bolts were "very loose". :eek: They removed the bolts, inspected for damage, replaced them and applied "Loktite", and also checked every other bolt under the car.

Now it's as tight as a drum... but it sure did raise my eyebrows about "Quality is Job #1" on the assembly line.... :roll:

_________________
Bob Worley, AKA bwcobra15
DHG #621
D-FW, Texas

<font size=-1>[ This Message was edited by: bwcobra15 on 2001-06-01 14:16 ]</font>
 
1 - 4 of 4 Posts
Top