Mustang Bullitt Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
710 Posts
Discussion Starter #1
Need some help, my A/C isnt working all it does is blow out warm air. I have checked the system and its fully charged. The compressor does however seem to kick in and then out quickly. Is there a sensor or relay that may be bad?
 

·
Registered
Joined
·
3,386 Posts
jp660605 said:
Need some help, my A/C isnt working all it does is blow out warm air. I have checked the system and its fully charged. The compressor does however seem to kick in and then out quickly. Is there a sensor or relay that may be bad?
You might want to check the compressor clutch as it sounds like it might be the problem. If it kicks in then quickly goes out then it is not building up enough pressure to mve the freon. Basically the compressor is more of a freon pump than an actual air compressor anyway.

NOTE: If you have the A/C compressor clutch changed it might be a good time to pull a vacuum on the system to remove any residual moisture even though it shows a full charge. Pull the vacuum for a while longer than minimum recommendation(s).

If the compressor is bad and you open the system then DEFINITELY also change the receiver drier before recharging with freon and refrigeration oil as the dessicant in the drier will more than likely be too wet and possibly cause the bag to break and shoot sand and/or silica particles all throughout your system (then you got REAL MAJOR PROBLEMS).

I hope this helps ... :~))
 

·
Registered
Joined
·
1,109 Posts
To me it sounds like the system is low on refrigerant. The compressor is short cycling, I would evacuate the system,recharge,dye, and look for leaks.
 

·
Registered
Joined
·
710 Posts
Discussion Starter #6
Thanks for the info so far, Im going to check on a price of a a/c clutch tomorrow. I was hoping for something a little simpler, but I kinda expected somthing like this. Im sure its not low on refrigerant as I checked the pressure and recharged it, so its on to the next guess.
 

·
Registered
Joined
·
1,011 Posts
Ac

There should be a pressure sensor on one of the hard lines. Please start by checking that. I had a bad one on a lincoln mark VII and the compressor kicked on and off constantly and it had a full charge also. Hope this helps.
 

·
Registered
Joined
·
710 Posts
Discussion Starter #8
Finally got back from my break and the A/C is fixed:smile: . I guess my gauge set is junk, all it needed was charged and it was quite low.
 

·
Registered
Joined
·
1,114 Posts
jp660605 said:
Finally got back from my break and the A/C is fixed:smile: . I guess my gauge set is junk, all it needed was charged and it was quite low.
why was it low?? a/c systems don't just leak. hopefully dye was put in and it can be found
 

·
Registered
Joined
·
710 Posts
Discussion Starter #10
Not sure why it was low, if it starts throwing out warm air again then I know it has a leak, shop I took it too is a friends. He said if it gets warm again to bring it back and we'll try some Red Angel sealer.
 

·
Registered
Joined
·
1,114 Posts
jp660605 said:
Not sure why it was low, if it starts throwing out warm air again then I know it has a leak, shop I took it too is a friends. He said if it gets warm again to bring it back and we'll try some Red Angel sealer.

sealer is the cheap way out...just have dye pumped in with the a/c r134a and then under with black light itll show up. look where its coming out and fix it right. i work on ac every now and then at work...i just hate seeing corners cut
 

·
Registered
Joined
·
710 Posts
Discussion Starter #12
I dont consider it cutting a corner but a temporary fix if there is a problem, until i can find the time and money to properly fix it.
 
1 - 12 of 12 Posts
Top