Mustang Bullitt Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
1,308 Posts
Discussion Starter #1
Hey, Bullitt racers, does anyone have a belt chirp when you speed/powershift into 3rd or 4th? Although it doesn't do that in second, 3rd and 4th chirps like crazy. I know its not traction because the noise is coming from straight in front of me. So I was just wondering...
 

·
Premium Member
Joined
·
8,327 Posts
Can you describe it? I get that (I think) as well, but its more like a squeal (to be honest, I thought it was the fuel pump, and not from under the hood).

It only happens when i am on it hard, and usually just when going to 2 to 3.

Mike
 

·
Registered
Joined
·
248 Posts
mine does the same "chirp", i checked the belt, it seems tight and as you said it only does it when i'm on it hard. hmmm will talk to the dealer next friday when it goes in for my "passive alarm" problem
 

·
Registered
Joined
·
16 Posts
I have belt chirp and squel. Also have a nice rub marking on the front of the Block where the Belt has hit it... The Not so bright people at the dealership said not to worry about it till it brakes. and they did not know what to do to check or fix it. I was wondering if the tesioner is not right due to the underdrive pullys ? any ideas??
 

·
Registered
Joined
·
1,308 Posts
Discussion Starter #5
Well, at least I'm not alone on this. I haven't done any engine inspection yet. I get it from 2-3, 3-4, and occasionally whenever it requires, 4-5th (120+ miles; no need to go that fast usually). I hope it doesn't break.
 

·
Registered
Joined
·
543 Posts
I also have markings (black greasy powder) on the front of the block where the belt has deposited this powder in two spots. However, I don't think the belt is rubbing on the block. How many other people are seeing this? Thanks.

John
 

·
Registered
Joined
·
248 Posts
update, replaced serpetine belt today at my dealer, and it got worse, he said my new belt is tighter, but it still "chirps".
he said maybe i'm not keeping my rpm's up enough when i shift, and when i shift the "launch" is a bit too much for the belt to try and keep up, it only does it on the
2-3, 3-4 shift.... any ideas??
 

·
Registered
Joined
·
10,357 Posts
The guys at 5.0 Super Ford also noticed this belt chirp when doing the comparison test of the Bullitt/Cobra. Great, well-done article in the December issue I think.
 

·
Registered
Joined
·
16 Posts
#4901 ask them if there is a test to see if the tension on the belt is right other than just feeling it ? I think it is the underdrive pullys but who knows mine has got better with time.
 

·
Registered
Joined
·
109 Posts
I have the same sound from the engine bay during hard shifts. Heard the same thing from my other GT. It seems to be belt slippage, not too concerned with it. I guess I will probably spin the belt loose tomorrow, just my luck..
 
1 - 10 of 10 Posts
Top