Mustang Bullitt Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
63 Posts
Discussion Starter #1
I just found out about this site a few days ago, I must say I really appreciate this forum because I really thought I was just too picky about the quality of the vehicle I bought (#00930). I have had many of the same problems others have been posting about.

One problem with mine, that I haven't read about yet, is the damage to the bottom of the splash guards I had on mine. The day after I picked it up I was washing it and noticed the driver's side splash guard was loose. The screw that mounted it to the finder was loose and wouldn't tighten. Under futher examination, I noticed that BOTH splash guards had deep grooves on the bottom of each guard, as if they were damaged when backing off the truck or something. The dealer had to order a new set and the new ones had to be painted. I waited almost two months for them to come in!

There's something else to check on your cars. Good luck!
 

·
Registered
Joined
·
151 Posts
I can top that, in a bad way. As I was driving off the lot with mine, I did not see the curb start and I ran over it. I heard a scrub, but thought it was just the front. When I got home, the splash guard was missing on the drivers side. The next day, I took it back to the dealer for them to clean it up, the salesman brought it out to me. The only damage was some scuffing on the underside and the hole the screw fits into was torn. They put a washer on it and it went right back on. I am still dreading the day I get the first door ding on it. I hate people that are not careful in parking lots. :sad:
 

·
Registered
Joined
·
4,591 Posts
When I picked up 1007 the left frt flap was loose and the screw was hanging out. The bodyman took 5 min. to install a anchor nut that was missing
 

·
Registered
Joined
·
310 Posts
My front left splash guard had only one clip holding it on and when i took the screw out it basically fell off and I found out the part that fits into the long body molding was bent at the factory but they stuffed it in anyway. Having the dealer fix it now I hope they dont try to pull a fast one because i will know :smile: Thanx Havgun #1676
 

·
BEST BULLITT Nats 06
Joined
·
13,041 Posts
Those frickin factory workers anyway! :evil:

I almost have to count on my toes how many little defects #344 had upon taking delivery! None of them major but they are all soooo irritating! Like what were the inspection people doing upon inspection anyway! Myabe they're just not as picky as we owners are when we go over them with fine toothed combs? They darn well should be! What if it was THEIR car!
 

·
Registered
Joined
·
144 Posts
The damaged splash guards are a problem because when shipping, the truck ramps are scraping the bottom of the guards, also knocking them loose and generally making a mess. If the dealership inspected the vehicle closely, they should have filed a damage claim with the carrier company. I had the same problem. Not serious enough to be a problem, but I ordered new ones anyway. Mine also came in missing the shift knob and door locks. I guess some dope at the rail yard has them on is 1987 Hyundai Excel now! It took 2 1/2 months for those parts to come in.
 
1 - 7 of 7 Posts
Top