Mustang Bullitt Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
92 Posts
Discussion Starter #1 (Edited)
okay, i need the best diagnostic guy in las vegas NV, if anyone knows anyone please help, i am hearing a funny clicking noise only around 2500-3500rpms, kinda like a crapy sounding machine gun from a B movie. hehe. please, any info would be much appreciated, i just need to find out what is wrong with this monster.
 

·
Registered
Joined
·
10,404 Posts
what gear are you in when hearing this noise.
 

·
Registered
Joined
·
92 Posts
Discussion Starter #3
do to my exhaust system being so damn loud i can for sure hear it in third and fourth, put i have to be very gentle on the throttle. first and second there is just toooooo much noise.
 

·
Registered
Joined
·
2,478 Posts
I want to see pics of this monster. If you are not a member, you can link them through Photobucket or something like that I think. While I'm at it, what kinda mods have you got?

Sorry I can't help diagnise the noise.
 

·
Premium Member
Joined
·
18,432 Posts
Plinging only when you move? Maybe your u-joints.Or pumpkin bearing noise. Bearings do that when they are dry/binding.

Try putting it on a lift and turn your wheels manually. You may need a stethescope-screwdriver to pin point the actual part.

If it's all the time even when the car is standing still it could be the throwout bearing or other part that is motion whenever the engine is running.

Just some (SWAGS) guesses. I'm no expert, sorry! :-(
 

·
Registered
Joined
·
92 Posts
Discussion Starter #6 (Edited)
well, the monster looks stock, except for the rear rims, i went with the 10.5 with the 315 nittos. other than that, auburn dif. 4.10 gears, alum. driveshaft, D&D t56 tranny (viper specs) dfx clutch, kooks full lenght headers, slp loudmouth cat back, heads port and polished same with intake manifold/throttle body?, built motor from ground up, custom fuel system, procharger, intercooler, yada yada yada. all in all putting 500rwhp to ground, and having fun doing it. in the next week or so i'll have the methanol kit installed so i get the 15 pounds i want out of the blower, only at twelve currently. except for the whole changing of tires with the oil every 3k miles gets expensive, but worth it. now i just need to peel off as much weight as possible, have no idea where to start though.
 

·
Car Whisperer
Joined
·
20,882 Posts
more diagnostics in the way of other info might help. When did it start, was it after any mods just being done, any brake issues lately, was the t-56 swap a used tranny or new, was the diff just done, etc.
 

·
Registered
Joined
·
92 Posts
Discussion Starter #9
this started about 6 weeks after having the new engine and tranny put in. what i think happened is i broke something while racing an evo on the freeway. it was the first time with the new engine that i got over 150mph. i noticed the noise about two days later. the clicking appears to e coming from the driver side. when riding shotgun u can barly hear it, but if your driving thats when it really is noticalbe.
just to answer your question, the tranny was brand new, and so was the entire engine, i was in a flash flood out here, destroying the old one, so i paid for everything new. block, ect.
i am heading to the shop this sat. to fun it on the dyno to find out if we can pinpoint the location. if anyone has an idea of where to start please give me a heads up. thanks guys
 

·
Registered
Joined
·
663 Posts
Running that kind of boost, at that speed, has been known to hurt even tough Terminator motors with bolt-on's (pulleys). I hope you had a good tune done when the motor was first running with that blower. A good tune can usually keep you safe from damage, at least on the air/fuel side of things.

Good luck!!
 
1 - 10 of 10 Posts
Top