Mustang Bullitt Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
141 Posts
Discussion Starter #1
Installed the full SLP set-up. (LTs, catted x-pipe, LMII). Sounds great. Also installed the H&R springs. Did the MM CC plates up front. Issue is, now the right side of the car sits about 1/2" - 1" higher than the left side! I have yet to get an alignment and I definitely have some preload in the control arm bushings.
Will this get fixed when I get an alignment or will I need to reinstall the springs (really don't want to do that)
 

·
Registered
Joined
·
14,703 Posts
You might make sure that both springs are correctly seated and aligned.
 

·
Registered
Joined
·
1,109 Posts
Yeah make sure you don't have a spring on back words. Get some pics up! We have to meet soon so I can check everything out.
 

·
Registered
Joined
·
987 Posts
R u reusing the old insolators?
 

·
Registered
Joined
·
4,271 Posts
Ge the alignment (cheap), then measure, before doing re-install (expensive). You'll need the alignment regardless. The vertical and horizontal settings will be definitely off after this kind of install.
 

·
Registered
Joined
·
141 Posts
Discussion Starter #6
Drove the car around last night a little more, semed to have leveled off. Only about 1/4" higher. Took her to evolution performance here in Aston (thanks Steve for the reference), they'll be doing the alighment and checking out the rest of what I put on. They're going to take care of the preload on the control arm bushings and check the hight and all, also check the exhaust, seems to be hanging a little low. Should get the car back tomorrow. Steve send me a PM with your number I'll give you a call if I have time. I'll be trying to post the before/after pics/vids once I get back to school (using a digital camera so not sure how the sound will come out).
 

·
Registered
Joined
·
141 Posts
Discussion Starter #7
Got the car back from the shop. Everytyhing taken care of. Nothing was wrong with the springs guess I was a bit paranoid.

VIDEOS
The quality isn't so great because I used my digital camera. Moreso with the SLP exhaust on.

The stock exhaust (Cold Start):
http://www.youtube.com/watch?v=Brt-xAE4bPw

2nd start with the new exhaust (Cold Start) (there were a couple leaks that are now fixed, and the exhaust is not yet broken in):
http://www.youtube.com/watch?v=anh6kLiCO74

Warm Start after the exhaust is a bit more broken in and no leaks (Warm Start):
http://www.youtube.com/watch?v=iKWRU6Y_5So

PICS (to come late december)
 

·
Registered
Joined
·
1,109 Posts
:clap: :clap: :clap: :clap: Sounds great. I dig the catted sound!
 

·
Registered
Joined
·
141 Posts
Discussion Starter #9
Yeah I love it. Still legal but still sooo loud. Couldn't imagine it without cats. Sounds louder and better in person I think it's shaking the camera so the sounds kind of muddy.

got another link too.

the B rev off vs. camaro SS, (both warm):
http://www.youtube.com/watch?v=543ieEewNTU


I also think these videos are kind of hidden here in this post so when I get the pics I'll put them all up in a new post, until then enjoy these :)
 

·
Registered
Joined
·
1,109 Posts
Did you do the install yourself?
 

·
Registered
Joined
·
141 Posts
Discussion Starter #11
Yep. Installed everything to save the bucks. Then took it to evolution performance and got the alignment, they gave me a great caster/camber setup, and they fixed the leaks and raised the exhaust an inch or so. A lot of time to do it all but worth it in my opinion.
 
1 - 11 of 11 Posts
Top