Mustang Bullitt Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Howdy! I was wondering if anyone else has had to pay too much attention to their PS fluid levels? I can't find a leak myself (hasn't been into the shop yet) but I have had to add fluid several times over the past couple of months...I first noticed the problem due to the fluid being real low and causing the PS to make "that noise" :smile:
 

·
Banned
Joined
·
535 Posts
I had the same problem. Couldn't figure out what the hell that noise was. Finally looked at the PS res and noticed it was really low. Added some juice and haven't had a problem since. I think that this is one the things that Ford was looking into??
 

·
Registered
Joined
·
74 Posts
i experienced that too. i notice i'm losing power steering fluids so i got it back to the dealer and they just retightened the power steering lines. and it's fixed!
 

·
Registered
Joined
·
198 Posts
No leaks here and the same song and dance.

Never mentioned it to the dealer.

Soon as that fluid level gets at the "MIN" the pump moans.

In my case, i think that the fluid is low cause they delaer spilled some in swapping the motor.

PLus it was low from day one.

Who knows...

Besides, the PS system looks really easy to service.
 

·
Premium Member
Joined
·
5,360 Posts
yes, mine started leaking around 3000 miles and there is a puddle on my garage floor. i can even smell the fluid burning from my engine compartment once in a while. so far, i ahven't had time to take it back in BUT i've only gone thru 3/4 of a bottle so far!
 

·
Registered
Joined
·
724 Posts
When I first got my Bullitt - I would go somewhere and leave a puddle. I thought it was oil at first so I took it to the dealership and they replaced my power steering pump. Twostangwomen had her's replaced also. I haven't had any problems since.
 

·
Premium Member
Joined
·
502 Posts
When I had mine on the rack to change the oil recently, I noticed a small leak around one of the lines as well. I did have a problem with my 92 several years ago. Apparently the rack was leaking around the seals into the dust boots. Could not figure out where all the fluid was going until one day one of the boots burst and spilled fluid all over the place. If you are loosing fluid and can't figure out where it is going, check the dust boots.
 

·
Registered
Joined
·
597 Posts
Mine is currently seeping around the hydro-boost unit which is what provides power assist for the brakes. Too lazy to fix it at the present time..lol.
 

·
Registered
Joined
·
7,944 Posts
227 had a leak but when they replaced the motor the leak went away. One of the lines was leaking. I had pointed it out to them when I gave them the car. Since the new engine it has been good.

Thanks

Bud
 

·
Registered
Joined
·
466 Posts
Just had to add fluid to mine last night. Have not seen evidence of a leak though. It is disheartening to see the same problems occurring in many of our cars.
 

·
Registered
Joined
·
899 Posts
Ford just replaced my pressure hose...
 
1 - 11 of 11 Posts
Top