Mustang Bullitt Forum banner

1 - 20 of 20 Posts

·
Registered
Joined
·
6,542 Posts
Discussion Starter #1
Well, my usual luck with things mechanical is holding. After getting to the stage of removing the wire harness plugs, the one on the passenger side will not budge. I have torn my right thumb, forfinger and middle finger raw trying to get the damn thing out. The drivers side one was a little stiff but, this one ain`t movin`. I have reassembled everything and refrained from taking my `97 Winchester 12 guage pump to the car.
Anyone have any ideas?
 

·
Registered
Joined
·
10,404 Posts
Both of mine were hard to pull apart Doc. I also know about the skin damage, I just kept pulling and moving side to side and they finally came apart. I did walk away for about 10 minutes and go back and started again.
 

·
Registered
Joined
·
2,090 Posts
You guys have convinced me. I am not even going to try!!! For me it would probably be worse.
 

·
Registered
Joined
·
6,542 Posts
Discussion Starter #4
rblack4405 said:
Both of mine were hard to pull apart Doc. I also know about the skin damage, I just kept pulling and moving side to side and they finally came apart. I did walk away for about 10 minutes and go back and started again.
I hear you.
I`ll go back to it in a few days.
 

·
Premium Member
Joined
·
1,458 Posts
If your having trouble unplugging the harness, try pressing down the tab with a screw driver or something. I had to do the same thing on mine, those connectors ar a real pita!
 

·
Registered
Joined
·
4,248 Posts
TheCat033 said:
If your having trouble unplugging the harness, try pressing down the tab with a screw driver or something. I had to do the same thing on mine, those connectors ar a real pita!
agreed on the pressing

not agreed on the pain in the ass part though :D

I was in and out in a hour with blowing dust out, doubling checking stuff/taking my time, and taking pictures :D

super easy.... a 5yr old could do this :D lol
good luck :) ;)
 

·
Registered
Joined
·
6,542 Posts
Discussion Starter #7
Yeah, a 5 year old with an iron grip.
 

·
Premium Member
Joined
·
2,412 Posts
I have to agree with Ezekial, very easy. As far as the plug, I did have to wiggle it a few times to get it to release, but it did. Putting the rings in required the slightest shaving of the plastic to get the rings to fit in. Knowing what to do now, it is a 10 - 15 miniute job at worst. Looks great.
 

·
Registered
Joined
·
771 Posts
I haven't had any plug issues so far. 4 different cars. 01 Bullitt, 01 GT, 02 GT, and an 04 Mach I
 

·
Premium Member
Joined
·
858 Posts
Just installed my Retro rings in about 35 min. They look great. Read instructions first for a change, made it simple.
 

·
Registered
Joined
·
29 Posts
It only took me about 30 mins. I put the rings in the freezer to help them snap into place easily. It worked great. Hardest part was dealing with the headlight knob. Luckily I have a billet one on the way.
 

·
Registered
Joined
·
899 Posts
Installed mine yesterday, nice simple upgrade
 

·
Registered
Joined
·
6,542 Posts
Discussion Starter #14
I`ll try again later this week. I can`t believe I am the only one to have a problem with this.:evil:
 

·
Registered
Joined
·
10,404 Posts
I had a problem with the plug also, just keep trying and it will happen.
 

·
Registered
Joined
·
899 Posts
Doc Coffin said:
I`ll try again later this week. I can`t believe I am the only one to have a problem with this.:evil:

Just make sure you depress the locking tabs on the connectors. I couldn't feel them at first and got kinda frustrated. Once I found them, no problem
 

·
Registered
Joined
·
48 Posts
Just leave it wired up.

Doc Coffin said:
Well, my usual luck with things mechanical is holding. After getting to the stage of removing the wire harness plugs, the one on the passenger side will not budge. I have torn my right thumb, forfinger and middle finger raw trying to get the damn thing out. The drivers side one was a little stiff but, this one ain`t movin`. I have reassembled everything and refrained from taking my `97 Winchester 12 guage pump to the car.
Anyone have any ideas?
I couldn't get mine off either, so I just left them wired up and removed the bezel cover. The harness wire is pretty long. If you tilt your steering wheel all the way down you can rest the gauge pod on it while you do the work.
 

·
Registered
Joined
·
6,542 Posts
Discussion Starter #18
Good advice. If i don`t work Friday I`m gonna try it again and if I still can`t pull the plug, I will do exactly that.
Thanks. :smile:
 

·
Registered
Joined
·
2,090 Posts
Would you do mine?

Rarecat said:
Installed mine yesterday, nice simple upgrade
If I drove down to G'ville, would you install them for me?
 

·
Registered
Joined
·
899 Posts
dennisbaker said:
If I drove down to G'ville, would you install them for me?
Sure, come on down.... if your serious, send me a PM and let me know when you want to do it...
 
1 - 20 of 20 Posts
Top