Mustang Bullitt Forum banner

1 - 20 of 20 Posts

·
Registered
Joined
·
110 Posts
Discussion Starter #1
Finished off the install of the Vortech Mongoose kit on my Bullitt this weekend - everything went well although took me a little longer than expected. The dissapointing thing is the noise that the unit makes - sounds like a rattling / grinding noise (kind of like an ice crushing machine!) especially noticeable at idle and when the unit is warm. I've checked the belt alignment and made sure I've got oil to the unit.

It's pretty dissapointing when you have been waiting for the stuff - then get it on and it sounds like a bag of nails! I checked on a few other forums and some people said theirs made the noise I was describing and some didn't.

I called Vortech today and sent them some sound clips so I'll see what they say when they get back to me. I've attached some pics of the install and vid clips of the noise.

http://video.google.co.uk/videoplay?docid=-3186834151660885529

http://video.google.co.uk/videoplay?docid=6516784510380847582
 

Attachments

·
Registered
Joined
·
899 Posts
Bummer, you've got a right to be ****ed off
 

·
Registered
Joined
·
10,404 Posts
Yep, they make noise---------and power
 

·
Registered
Joined
·
279 Posts
I have had many Vortech's and none of them have sounded like what you are describing. I would take it off and make sure none of the puuleys are in contact with something. Also spin it freely. You could just start by taking the belt off and spinning it. It should be smooth. Look at the impeller and make sure it isn't loose or hitting anything. It should make a whistle but not a crunching noise. Did you go with the V-1 or V-2? The V-2 would be pretty quiet.
 

·
Premium Member
Joined
·
3,509 Posts
Well done you didn't waste any time fitting your kit, sorry to hear it's noisy
hope it is a quick fix.

Edit.
Just watched the videos and that sounds badddd ! ! !
Like the bearings are shot.

Bob
 

·
Registered
Joined
·
110 Posts
Discussion Starter #8
Well I took the unit off again today and it seems to spin freely enough by hand but there is a slight mechanical knocking sound. I've send some sound clips to Vortech to see what they say. Getting mixed views of others with Vortech's. Some say they are getting a simialr kind of noise while others are not. At least it has a 3 year warranty with it!
 

·
Premium Member
Joined
·
1,025 Posts
I've been running a Vortech V-1 S-trim on another car of mine (non-Bullitt), and although I have not had the knocking sound come from my unit, I have heard of others making that noise. It seems from my research that some come from the factory making that noise, while others do not. It's amazing the different sounds those little suckers make even when they are the same model. I'm assuming it's the variance in the manufacturing process. Vortech has pretty good customer service. If you feel that it is something they need to fix, I wouldn't hesitate sending it to them for inspection/repair. It's frustrating to say in the least, but after spending the time and money you should get what you paid for.
 

·
Registered
Joined
·
1,109 Posts
I know nothing about blowers, but I would agree that somthing is not right. Its sounds like a bearing issue.
 

·
Registered
Joined
·
14,703 Posts
rblack4405 said:
Send it back and have them check it.
This is what I would do. Otherwise you will have to wait until it breaks down on you and then send it in. Mine is very quiet on the car, especially when warm. Just a slight whistle.
 

·
Registered
Joined
·
10,404 Posts
My first one puked at 1800 miles, almost 900 miles from home.
 

·
Registered
Joined
·
4,763 Posts
i have the mongoose kit as well. that knocking doesnt sound good. maybe a washer or somthing is in with the impeller? idk id take it off and shack it a little to see if maybe there is somthing inside. I thought the noise mine made was bad but found out that it was fine.
 

·
Registered
Joined
·
110 Posts
Discussion Starter #16
I got an email from Vortech today saying they thought it was normal! I called them up and I'm going to send the unit back to them for inspection. I guess it's the best thing to do in the long run even though it's extremely frustrating!!! - and I have to pay to get the unit shipped back to them.
 

·
Banned
Joined
·
7,235 Posts
I would send it back ASAP,for another unit.I wouldn't put up with that kind of noise.
Suppose something comes loose in the unit and gets sucked up into your engine! Noise means something metalic is hitting something which could be generating small metal particles.
 

·
Registered
Joined
·
4,763 Posts
oz said:
I got an email from Vortech today saying they thought it was normal! I called them up and I'm going to send the unit back to them for inspection. I guess it's the best thing to do in the long run even though it's extremely frustrating!!! - and I have to pay to get the unit shipped back to them.
that noise isnt normal
 

·
Registered
Joined
·
110 Posts
Discussion Starter #19
Fedex came today to pick up the Vortech. Now I have to sit and wait again! Vortech say a turn around of 1 1/2 weeks. I told Vortech in the letter I sent with the package that I thought the noise was unacceptable and they should replace or rectify before sending back to me.
 

·
Registered
Joined
·
4,763 Posts
oz said:
Fedex came today to pick up the Vortech. Now I have to sit and wait again! Vortech say a turn around of 1 1/2 weeks. I told Vortech in the letter I sent with the package that I thought the noise was unacceptable and they should replace or rectify before sending back to me.
a high pitch noise is normal, but the whole clunking like there is something inside the unit is unacceptable
 
1 - 20 of 20 Posts
Top