Mustang Bullitt Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
724 Posts
Discussion Starter #1
I have a little scrape mark on my e-brake boot, it looks like it's caused by rubbing up and down from the plastic on the right side. Anyone else have this problem??
 

·
Registered
Joined
·
822 Posts
the leather/vinyl on mine cut through...I took it to the dealer and they replaced it. Upon closer inspection..what it was...was the e-brake was actually slightly bent and that caused it to rub every time I lifted it up or put it down. Something everyone should look out for, to prevent that from happening to your cars.
 

·
Registered
Joined
·
2,114 Posts
The service manager I delt with said 'they all do that'... but I got them to replace the boot and center the handle.
 

·
Registered
Joined
·
75 Posts
Yeah, our Bullitt's leather brake cover has a small tear in it as well from using the e-brake. We are going to have ours replaced later on before warranty is up. Right now, it's not a big deal. Anyone else noticing that the leater wrap around the steering wheel is showing excessive wear? Ours is, and the Bullitt only has a little over 1300 miles on it.
 

·
Registered
Joined
·
509 Posts
That's from gripping it so hard under heavy acceleration!
 

·
Registered
Joined
·
1,065 Posts
<TABLE BORDER=0 ALIGN=CENTER WIDTH=85%><TR><TD><font size=-1>Quote:</font><HR></TD></TR><TR><TD><FONT SIZE=-1><BLOCKQUOTE>
On 2001-12-15 11:11, Reader wrote:
Anyone have excessive play in the E-Brake? Mine moves about 2 to 3 inches with out button application.
</BLOCKQUOTE></FONT></TD></TR><TR><TD><HR></TD></TR></TABLE>
Yeah, Mine plays up and down a few inches too, but I never noticed it and don't think it did it until recently when I cleaned and readjusted the boot. Maybe that had something to do with it?
 

·
Registered
Joined
·
320 Posts
Yeh I have that play too, I thought there was something wrong but my buddies 02 gt does it too. My 95 didnt though.
 
1 - 8 of 8 Posts
Top