Mustang Bullitt Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1,840 Posts
Discussion Starter #1
I'm heading out tomorrow morning to Ark City for the MAD/WACO event. (Mid America Drag/Wichita Area Chevelle Owners) Taking 4415 and a 67 Elcamino to see what times we can get out of them. I'm stock except for an O/R x-pipe, and this is my first time at the track with the car, so I'm hoping to dip into the 13's with the Bullitt. Trying to get some runs in for practice before the Nat's next month. I plan on taking the video camera so I'll try to get some vids and pics up.
 

·
Registered
Joined
·
1,840 Posts
Discussion Starter #2
Well, a little slower than I expected, but not bad for the first time in the car. Best was a 14.45 @ 96mph with a 2.289 60ft and a .749 RT. My best RT was .52 on a .5 tree, but that was one of the slower runs where I missed 2nd gear. My trac-loc's giving out so I only had 1 wheel spinning so even if I babied it out of the hole when I get back into it, just wheelspin in 1st gear. Others were complaining about the slippery track and the head wind as well, but I think I did decent. I have a vid but no real footage of the Bullitt since I was the cameraman. Some decently fast cars showed up. Most were between 10 and 12 second cars with a couple in the 9's. There's a Hyabusa that ran 9.4's without a power adder or wheelie bar. I'm getting the cam charged back up and I'll try to post up the vid later tonight.
 

·
Registered
Joined
·
2,965 Posts
thats not a bad time at all. track prep is key. my local track absolutely sucks. i've got full exhaust, 295 bfg's, some other stuff... last week my best was 14.1 with a 2.4 60' time :grumpy: i ran better than that when i was stock!
couple more times out and you'll be in the 13's!!!!
 
1 - 3 of 3 Posts
Top