Mustang Bullitt Forum banner
1 - 7 of 7 Posts

·
Premium Member
Joined
·
4,220 Posts
Discussion Starter · #1 ·
My Bullitt is about 7 months old now and I have gone through 4 trunk mounted antennas now. My last antenna lasted about 3 weeks!
I am going to have all new cable run thru my Bullitt this time, with the new antenna.
Do you guys have any other ideas?
 

·
Registered
Joined
·
282 Posts
What is happening that you need a new one?
 

·
Registered
Joined
·
2,319 Posts
I will tell you there are a grand total of 3 connectors on the antenna wire. One close to the antenna, one at the base of the trunk lid, and one at the sirius tuner in the trunk, pass side behind the carpet trim panel. Could be any one of these connectors, or any one of these cables. I would need to test each section to see if any part were bad.

BTW, if any part of the antenna system (antenna, cable or connectors) is bad, it will show "antenna" error on the radio display, so it may not be the antenna itself that is bad.
 

·
Premium Member
Joined
·
4,220 Posts
Discussion Starter · #5 ·
The radio say no signal.
When I call Sirius they tell me it is always something with the antenna. So I change the lady bug on the trunk and then it works for a while
 

·
Registered
Joined
·
172 Posts
BlackPony said:
The radio say no signal.
When I call Sirius they tell me it is always something with the antenna. So I change the lady bug on the trunk and then it works for a while
Now you have given me an idea of how to paint my antenna!
 

·
Premium Member
Joined
·
4,220 Posts
Discussion Starter · #7 ·
Now thats FUNNY:lol:
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top