Mustang Bullitt Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2,090 Posts
Discussion Starter #1
Can some of you share your experiences with a clunky loose feeling transmission. Mine feels loose and clunky, especially when I put it in reverse, back up, and then let the clutch out. This results in a clanging sound. Overall, what I am feeling and hearing is hard to describe but in non-mechanical terms it just seems like the transmission has to have a certain amount of tension on it to feel like it should. I drove my car today and I seemed to be more aware of how it felt after having driven a Shelby GT a few days ago that shifted like a dream compared to by Bullitt. Thoughts please.
 

·
Registered
Joined
·
923 Posts
Hi Dennis,
About a year ago, I had the throw-out bearing changed in 3143 and they told me the transmission WAS loose. I could feel it on take-off in the shifter, like the transmissions was trying to roll against the bell-housing. After they tightened it, it wasn't so bad.

KO
 

·
Registered
Joined
·
258 Posts
Dennis

This past April I installed a MGW shifter, which I do like. Shortly after the install, I noticed more noise when I shift or even when in neutral. Hard to describe, but it's like a grinding type sound. I really don't like it at all. I had a friend who knows cars more than I do listen and he thought maybe a tranny oil change was in order. It has 19k and never had it changed. So I had that done, but it's still a bit noisy. When I installed the MGW shifter, I did not purchase the $8 inner dust boot. I have wondered if that would make a difference. I just hope my tranny isn't going out. It's in storage now so I am going to have it checked in April when I get it out.
Does this sound similiar to your issue?
 

·
Registered
Joined
·
90 Posts
I do also have a 'ringing' sound from time to time... I haven't been able to point what causes it. But some days it gets really bad and some others you can't ever hear it.
 

·
Registered
Joined
·
2,090 Posts
Discussion Starter #5
More about my problem

BullittJon said:
This past April I installed a MGW shifter, which I do like. Shortly after the install, I noticed more noise when I shift or even when in neutral. Hard to describe, but it's like a grinding type sound. I really don't like it at all. I had a friend who knows cars more than I do listen and he thought maybe a tranny oil change was in order. It has 19k and never had it changed. So I had that done, but it's still a bit noisy. When I installed the MGW shifter, I did not purchase the $8 inner dust boot. I have wondered if that would make a difference. I just hope my tranny isn't going out. It's in storage now so I am going to have it checked in April when I get it out.
Does this sound similiar to your issue?
I think my problem is different. I get a clattering sound when driving in a tight circle and dumping it into neutral and at the same time I get a throbbing in the shifter. When I straighten the front wheels the noise stops. All of this only happens after the car is really warmed up by driving for about 20-30 minues.
 
1 - 5 of 5 Posts
Top