Mustang Bullitt Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Hey everyone! Just bought a 2001 Bullitt, drove it three states home to California, had zero issues.

But upon making it home, like a dummy I left the key in the ignition "ON" position overnight, so car was dead this morning.

Jumped the car, letting it charge about 5 minutes. Turn the key and no other lights are illuminated beyond the THEFT light on solid (no blinking). Exterior lights are working if dim but no cranking or clicking from the engine...No matter how long I charge the battery, it's like the theft system is stopping the car from even attempting to start.

I figure disconnecting the battery to let the computer reset. Nothing. Try jumping it again. Nothing.

Car was running perfectly before this so it must be some battery/theft system procedure that I'm not familiar with.

Any ideas would be hugely appreciated from this Bullitt noob!


=== This is an automatically generated message ===

This is my first post. My Welcome thread is here. Please post all my welcome message there.

=== This is an automatically generated message ===
 

·
Car Whisperer
Joined
·
20,881 Posts
^^^^what he said, plus, if you completely drained it, possibly, even jumping from another car may not do it. I would have the battery checked first.
 

·
Registered
Joined
·
185 Posts
Check your owners manual. if you have a security system problem, the security light in the dash is supposed to flash or stay on. If not, put a volt meter on the battery and see if it hold juice.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #5
UPDATE- FIXED!

Just got a brand new battery and swapped it out. Before starting, just to be cautious, I locked and unlocked the door with the key fob. Started right up with all our keys! Computer didn't even reset.

I think I must've psyched myself out thinking it was a worse problem than that, considering all the PATS problems I've read about.

The battery was from 2009, so was good time to replace it anyways. Thanks everyone.
 

·
Car Whisperer
Joined
·
20,881 Posts
cool!!! battery it was and easy fix!!! Enjoy!!!!!!!!!

remember.......these newer cars...that is, computer cars. need voltage. if the computer reads low voltage....it will not run or do all manner of weird things. that is or should be one of the first things to check on modern age cars....BATTERY!!!!!!!!!
 
1 - 6 of 6 Posts
Top